re = /echo: (?<sound>\S+)(?:(?<lostAndNoise>.+)(?<echo>\k<sound>))+/m
str = 'echo: yahoo yaha yaho ah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end