package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w\.]+\@[\w]+(?:\.[\w]{3}|\.[\w]{2}\.[\w]{2})\b`)
var str = `boleh di kirim ke email saya ekoprasetyo.crb@outlook.com tks...
boleh minta kirim ke db.maulana@gmail.com.
dee.wien@yahoo.com. .
deninainggolan@yahoo.co.id Senior Quantity Surveyor
Fajar.rohita@hotmail.com, terimakasih bu Cindy Hartanto
firmansyah1404@gmail.com saya mau dong bu cindy
fransiscajw@gmail.com
Hi Cindy ...pls share the Salary guide to me me, you <donny_tri_wardono@yahoo.co.id> thank a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}