# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\w\.]+\@[\w]+(?:\.[\w]{3}|\.[\w]{2}\.[\w]{2})\b"
test_str = ("boleh di kirim ke email saya ekoprasetyo.crb@outlook.com tks...\n"
"boleh minta kirim ke db.maulana@gmail.com. \n"
"dee.wien@yahoo.com. .\n"
"deninainggolan@yahoo.co.id Senior Quantity Surveyor\n"
"Fajar.rohita@hotmail.com, terimakasih bu Cindy Hartanto\n"
"firmansyah1404@gmail.com saya mau dong bu cindy\n"
"fransiscajw@gmail.com \n"
"Hi Cindy ...pls share the Salary guide to me me, you <donny_tri_wardono@yahoo.co.id> thank a")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.