import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w\\.]+\\@[\\w]+(?:\\.[\\w]{3}|\\.[\\w]{2}\\.[\\w]{2})\\b";
final String string = "boleh di kirim ke email saya ekoprasetyo.crb@outlook.com tks...\n"
+ "boleh minta kirim ke db.maulana@gmail.com. \n"
+ "dee.wien@yahoo.com. .\n"
+ "deninainggolan@yahoo.co.id Senior Quantity Surveyor\n"
+ "Fajar.rohita@hotmail.com, terimakasih bu Cindy Hartanto\n"
+ "firmansyah1404@gmail.com saya mau dong bu cindy\n"
+ "fransiscajw@gmail.com \n"
+ "Hi Cindy ...pls share the Salary guide to me me, you <donny_tri_wardono@yahoo.co.id> thank a";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}