package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:0|63)?\d{10}\b`)
var str = `09187654321
09187654321
6311111111
631111111111
06311111111
63111111111
011111111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}