import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:0|63)?\\d{10}\\b";
final String string = "09187654321\n"
+ "09187654321\n"
+ "6311111111\n"
+ "631111111111\n"
+ "06311111111\n\n\n"
+ "63111111111\n"
+ "011111111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}