#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\.message\((?s)(.+?)\)\s*(?:\.(?:log|build)\(\)\s*)+\s*;"
Local $sString = ".message("Lorem ipsum dolor sit amet, consectetur adipiscing elit. :{}" + id).build().log();" & @CRLF & _
"" & @CRLF & _
".message("Lorem ipsum dolor: " + object.getProperty()).someOtherMethod()).log();" & @CRLF & _
"" & @CRLF & _
".message("Lorem ipsum dolor: " + object.getProperty()).build().log();" & @CRLF & _
"" & @CRLF & _
".message(" pretium mi at iaculis. Quisque bibendum {} "+ error.getMessage())" & @CRLF & _
".build().log();" & @CRLF & _
" " & @CRLF & _
".message("vel pharetra est urna eget justo. Nunc in dignissim velit. {} "" & @CRLF & _
" + error.getMessage().getProperty())" & @CRLF & _
".build().log();" & @CRLF & _
" " & @CRLF & _
".message("Key : " + oldEntry.getKey() + " and Value: " + oldEntry.getValue())" & @CRLF & _
".build()" & @CRLF & _
".log();" & @CRLF & _
"" & @CRLF & _
".message("Curabitur vel facilisis ante.: "" & @CRLF & _
" + information.getProfile().getId())" & @CRLF & _
".build()" & @CRLF & _
".log();"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")