const regex = /\.message\((?s)(.+?)\)\s*(?:\.(?:log|build)\(\)\s*)+\s*;/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.message\\((?s)(.+?)\\)\\s*(?:\\.(?:log|build)\\(\\)\\s*)+\\s*;', 'g')
const str = `.message("Lorem ipsum dolor sit amet, consectetur adipiscing elit. :{}" + id).build().log();
.message("Lorem ipsum dolor: " + object.getProperty()).someOtherMethod()).log();
.message("Lorem ipsum dolor: " + object.getProperty()).build().log();
.message(" pretium mi at iaculis. Quisque bibendum {} "+ error.getMessage())
.build().log();
.message("vel pharetra est urna eget justo. Nunc in dignissim velit. {} "
+ error.getMessage().getProperty())
.build().log();
.message("Key : " + oldEntry.getKey() + " and Value: " + oldEntry.getValue())
.build()
.log();
.message("Curabitur vel facilisis ante.: "
+ information.getProfile().getId())
.build()
.log();`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}