// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\.message\((?s)(.+?)\)\s*(?:\.(?:log|build)\(\)\s*)+\s*;").unwrap();
let string = ".message(\"Lorem ipsum dolor sit amet, consectetur adipiscing elit. :{}\" + id).build().log();
.message(\"Lorem ipsum dolor: \" + object.getProperty()).someOtherMethod()).log();
.message(\"Lorem ipsum dolor: \" + object.getProperty()).build().log();
.message(\" pretium mi at iaculis. Quisque bibendum {} \"+ error.getMessage())
.build().log();
.message(\"vel pharetra est urna eget justo. Nunc in dignissim velit. {} \"
+ error.getMessage().getProperty())
.build().log();
.message(\"Key : \" + oldEntry.getKey() + \" and Value: \" + oldEntry.getValue())
.build()
.log();
.message(\"Curabitur vel facilisis ante.: \"
+ information.getProfile().getId())
.build()
.log();";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}