import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(fox)(?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)";
final String string = "Normal: The quick brown fox jumps over the lazy dog. \n"
+ "Speechmarks: \"The quick brown fox jumps over the lazy dog\" ?\n"
+ "Part of Word: The quick brown foxy-woxy jumps over the lazy dog.\n"
+ "Caps: The quick brown Fox jumps over the lazy dog.\n\n"
+ "Normal: The quick brown fox jumps over the lazy dog. \n"
+ "Speechmarks: \"The quick brown fox jumps over the lazy dog\" \n"
+ "Part of Word: The quick brown foxy-woxy jumps over the lazy dog.\n"
+ "Caps: The quick brown Fox jumps over the lazy dog.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}