$re = '/(?i)(fox)(?=(?:[^"]*"[^"]*")*[^"]*$)/';
$str = 'Normal: The quick brown fox jumps over the lazy dog.
Speechmarks: "The quick brown fox jumps over the lazy dog" ?
Part of Word: The quick brown foxy-woxy jumps over the lazy dog.
Caps: The quick brown Fox jumps over the lazy dog.
Normal: The quick brown fox jumps over the lazy dog.
Speechmarks: "The quick brown fox jumps over the lazy dog"
Part of Word: The quick brown foxy-woxy jumps over the lazy dog.
Caps: The quick brown Fox jumps over the lazy dog.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);