import Foundation
let pattern = #"(?i)(fox)(?=(?:[^"]*"[^"]*")*[^"]*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Normal: The quick brown fox jumps over the lazy dog.
Speechmarks: "The quick brown fox jumps over the lazy dog" ?
Part of Word: The quick brown foxy-woxy jumps over the lazy dog.
Caps: The quick brown Fox jumps over the lazy dog.
Normal: The quick brown fox jumps over the lazy dog.
Speechmarks: "The quick brown fox jumps over the lazy dog"
Part of Word: The quick brown foxy-woxy jumps over the lazy dog.
Caps: The quick brown Fox jumps over the lazy dog.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)