using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[A-Z]\w*\b.*?>|(?<=>)(\w+)(?=<)";
string input = @"<Component><Box><Inline><Text>Hello</Text></Inline></Box></Component>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}