re = /<[A-Z]\w*\b.*?>|(?<=>)(\w+)(?=<)/m
str = '<Component><Box><Inline><Text>Hello</Text></Inline></Box></Component>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end