$re = '/<[A-Z]\w*\b.*?>|(?<=>)(\w+)(?=<)/m';
$str = '<Component><Box><Inline><Text>Hello</Text></Inline></Box></Component>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);