$re = '/\b(?!333333\b)\d{6}\b/m';
$str = '333333 123456 333333,123456!Vasya1234560000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);