re = /\b(?!333333\b)\d{6}\b/m
str = '333333 123456 333333,123456!Vasya1234560000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end