package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-z0-9][?!.])\s.*`)
var str = `Bali bombings: U.S. President George W. Bush amongst many others has condemned the perpetrators of the Bali car bombing of October 11. The death toll has now risen to at least 187.`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}