re = /([a-z0-9][?!.])\s.*/
str = 'Bali bombings: U.S. President George W. Bush amongst many others has condemned the perpetrators of the Bali car bombing of October 11. The death toll has now risen to at least 187.'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result