const regex = /([a-z0-9][?!.])\s.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z0-9][?!.])\\s.*', 'g')
const str = `Bali bombings: U.S. President George W. Bush amongst many others has condemned the perpetrators of the Bali car bombing of October 11. The death toll has now risen to at least 187.`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);