# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?[a-z0-9][.?!](?= )/\1/g;t' <<< "Bali bombings: U.S. President George W. Bush amongst many others has condemned the perpetrators of the Bali car bombing of October 11. The death toll has now risen to at least 187."