#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*?[a-z0-9][.?!](?= )"
Local $sString = "Bali bombings: U.S. President George W. Bush amongst many others has condemned the perpetrators of the Bali car bombing of October 11. The death toll has now risen to at least 187."
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)