using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?[a-z0-9][.?!](?= )";
string substitution = @"\1";
string input = @"Bali bombings: U.S. President George W. Bush amongst many others has condemned the perpetrators of the Bali car bombing of October 11. The death toll has now risen to at least 187.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}