package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?:\/\/(.*?)\/.*$`)
var str = `https://api.github.com/rest/getusername
http://api.google.com/rest/getusername
ftp://api.whatever.com/rest/getusername`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}