re = /^https?:\/\/(.*?)\/.*$/m
str = 'https://api.github.com/rest/getusername
http://api.google.com/rest/getusername
ftp://api.whatever.com/rest/getusername'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end