package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https?|ftp):\/\/[^\s\/$.?#].[^\s]*$`)
var str = `https://apis.mappls.com
http://localhost:XXXX
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}