re = /^(https?|ftp):\/\/[^\s\/$.?#].[^\s]*$/m
str = 'https://apis.mappls.com
http://localhost:XXXX
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end