$re = '/^(https?|ftp):\/\/[^\s\/$.?#].[^\s]*$/m';
$str = 'https://apis.mappls.com
http://localhost:XXXX
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);