using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@\s*\K\d+?(?=900)";
string input = @"asdfsdf
@ 1234900 asdf dfasd
asdf @ 1345900-asdfad wer
@ 678900-asdfa adf ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}