re = /@\s*\K\d+?(?=900)/m
str = 'asdfsdf
@ 1234900 asdf dfasd
asdf @ 1345900-asdfad wer
@ 678900-asdfa adf '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end