import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@\\s*\\K\\d+?(?=900)";
final String string = "asdfsdf\n"
+ "@ 1234900 asdf dfasd\n"
+ "asdf @ 1345900-asdfad wer\n"
+ "@ 678900-asdfa adf ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}