package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z0-9\-_\.]+):([0-9]{1,5})`)
var str = `178.33.37.215:9999
213.136.87.38:8118
139.5.71.126:23500
138.201.223.250:31288`
var substitution = ""$1:$2";"2019-05-17""
fmt.Println(re.ReplaceAllString(str, substitution))
}