re = /([a-zA-Z0-9\-_\.]+):([0-9]{1,5})/m
str = '178.33.37.215:9999
213.136.87.38:8118
139.5.71.126:23500
138.201.223.250:31288'
subst = '"$1:$2";"2019-05-17"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result