using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[()+\-*\/]|\d+";
string input = @"1+2+3
2/1*100
1+2+3/3*100
(1*2)/(3*4)*100";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}