$re = '/[()+\-*\/]|\d+/';
$str = '1+2+3
2/1*100
1+2+3/3*100
(1*2)/(3*4)*100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);