package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[()+\-*\/]|\d+`)
var str = `1+2+3
2/1*100
1+2+3/3*100
(1*2)/(3*4)*100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}