#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\b:?[A-Z]{1,3}[0-9]{1,10}){1,2}$"
Local $sString = "A1" & @CRLF & _
"A1:C4" & @CRLF & _
"AB:AB" & @CRLF & _
"A1:A1:" & @CRLF & _
"1:1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")