// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\b:?[A-Z]{1,3}[0-9]{1,10}){1,2}$").unwrap();
let string = "A1
A1:C4
AB:AB
A1:A1:
1:1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}