package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\b:?[A-Z]{1,3}[0-9]{1,10}){1,2}$`)
var str = `A1
A1:C4
AB:AB
A1:A1:
1:1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}