using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_(Aircraft \w+?)_.+(\d{2}[a-z]{3}\d{4})-";
string input = @"__XXXXXXXX_XXX_XXXXXXX_XXXX_XXXXX_XXXX XXX_Aircraft 017_XXXXXXXX-XXXXXXX_XXXXXXX-XXXXXXX-XXXXXX-01Apr2021-XXXXX";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}