re = /_(Aircraft \w+?)_.+(\d{2}[a-z]{3}\d{4})-/i
str = '__XXXXXXXX_XXX_XXXXXXX_XXXX_XXXXX_XXXX XXX_Aircraft 017_XXXXXXXX-XXXXXXX_XXXXXXX-XXXXXXX-XXXXXX-01Apr2021-XXXXX'
# Print the match result
str.match(re) do |match|
puts match.to_s
end