package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)_(Aircraft \w+?)_.+(\d{2}[a-z]{3}\d{4})-`)
var str = `__XXXXXXXX_XXX_XXXXXXX_XXXX_XXXXX_XXXX XXX_Aircraft 017_XXXXXXXX-XXXXXXX_XXXXXXX-XXXXXXX-XXXXXX-01Apr2021-XXXXX`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}