# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\w+\s)[\d\s]+/\1/gm;t' <<< "Mywebsite 21 12 34 have 10000 traffic"