use strict;
my $str = 'Mywebsite 21 12 34 have 10000 traffic';
my $regex = qr/^(\w+\s)[\d\s]+/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";