import re
regex = re.compile(r"^(\w+\s)[\d\s]+", flags=re.MULTILINE)
test_str = "Mywebsite 21 12 34 have 10000 traffic"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)