#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:ts(?:m(?:09|1[0-9]|20))?|edtd\-ts)\.eset\.com$"
Local $sString = "tsm09.eset.com" & @CRLF & _
"tsm10.eset.com" & @CRLF & _
"tsm11.eset.com" & @CRLF & _
"tsm12.eset.com" & @CRLF & _
"tsm13.eset.com" & @CRLF & _
"tsm14.eset.com" & @CRLF & _
"tsm15.eset.com" & @CRLF & _
"tsm16.eset.com" & @CRLF & _
"tsm17.eset.com" & @CRLF & _
"tsm18.eset.com" & @CRLF & _
"tsm19.eset.com" & @CRLF & _
"tsm20.eset.com" & @CRLF & _
"ts.eset.com" & @CRLF & _
"edtd-ts.eset.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")