import re
regex = re.compile(r"^(?:ts(?:m(?:09|1[0-9]|20))?|edtd\-ts)\.eset\.com$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("tsm09.eset.com\n"
"tsm10.eset.com\n"
"tsm11.eset.com\n"
"tsm12.eset.com\n"
"tsm13.eset.com\n"
"tsm14.eset.com\n"
"tsm15.eset.com\n"
"tsm16.eset.com\n"
"tsm17.eset.com\n"
"tsm18.eset.com\n"
"tsm19.eset.com\n"
"tsm20.eset.com\n"
"ts.eset.com\n"
"edtd-ts.eset.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")