const regex = /<([a-z]+@[a-z]+(\.[a-z]{2,3}){1,2})>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<([a-z]+@[a-z]+(\\.[a-z]{2,3}){1,2})>', 'gi')
const str = `"Meu nome <meuNome@email.com.br>";
"Meu nome <meuNome@email.com>";
"Meu nome <a@b.com.br>";
"Meu nome <teste de conteudo>";
"Meu nome <testede@conteudo>";
"Meu nome <var1>var2>";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}