import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([^>]+)>";
final String string = "\"Meu nome <meuNome@email.com.br>\";\n\n"
+ "\"Meu nome <meuNome@email.com>\";\n\n"
+ "\"Meu nome <a@b.com.br>\";\n\n"
+ "\"Meu nome <teste de conteudo>\";\n\n"
+ "\"Meu nome <testede@conteudo>\";\n\n"
+ "\"Meu nome <var1>var2>\";";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}