# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<([^>]+)>"
test_str = ("\"Meu nome <meuNome@email.com.br>\";\n\n"
"\"Meu nome <meuNome@email.com>\";\n\n"
"\"Meu nome <a@b.com.br>\";\n\n"
"\"Meu nome <teste de conteudo>\";\n\n"
"\"Meu nome <testede@conteudo>\";\n\n"
"\"Meu nome <var1>var2>\";")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.